Husqvarna Norden Forum banner
1 - 12 of 12 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
Hey there,

Just wanted to see if anyone else has experience this or figured out a fix.
I’ll set Ride Mode into my quick selection favourites. Within a day the bike will forget it. ABS mode will stay saved. But Ride Mode is just gone. It doesn’t matter if I set it as up or down for the favourite. It forgets both. Kind of frustrating.

Cheers

John
 

·
Registered
Joined
·
131 Posts
Hey there,

Just wanted to see if anyone else has experience this or figured out a fix.
I’ll set Ride Mode into my quick selection favourites. Within a day the bike will forget it. ABS mode will stay saved. But Ride Mode is just gone. It doesn’t matter if I set it as up or down for the favourite. It forgets both. Kind of frustrating.

Cheers

John
I'm noticing this when I go into Explore mode and then back. I like to ride with the "reduced" or "no favorites" interface but after I turn Explorer mode off, it resets back to "favorites" interface mode. I also lose my quick select buttons that I've programmed. My solution is to keep the Explore mode on all the time, it really helps me wheelie better also, lol... I wish there was a separate button to turn on the ABS when in Explore mode without having to go through the menu. It's very distracting to do this while riding.

Maybe they will address this in a software update...
 

·
Registered
Joined
·
141 Posts
I'm noticing this when I go into Explore mode and then back. I like to ride with the "reduced" or "no favorites" interface but after I turn Explorer mode off, it resets back to "favorites" interface mode. I also lose my quick select buttons that I've programmed.
Same happens to me. I plan to mention it next week when I take my bike in for the false neutral issue.
 

·
Registered
Joined
·
26 Posts
My bike doesn't always remain in explorer mode after I have it set. That really did a number on my energy when riding sand this weekend. Thought I was good to go in explorer. Ended ass up a few times to find I was in street mode. I'd remember to check every time if it was consistent.
 

·
Registered
Joined
·
131 Posts
My bike doesn't always remain in explorer mode after I have it set. That really did a number on my energy when riding sand this weekend. Thought I was good to go in explorer. Ended ass up a few times to find I was in street mode. I'd remember to check every time if it was consistent.
One cool feature is the "H" gun sight logo is yellow on the startup screen when in Explorer mode, any other mode and it's white...
Hood Automotive tire Motor vehicle Bumper Personal computer
 

·
Registered
Joined
·
7 Posts
My bike doesn't always remain in explorer mode after I have it set. That really did a number on my energy when riding sand this weekend. Thought I was good to go in explorer. Ended ass up a few times to find I was in street mode. I'd remember to check every time if it was consistent.
What I have learned is to wait for the dash to fully boot up before hitting the start button. If not not the ride mode reverts to roa.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #10 ·
My bike doesn't always remain in explorer mode after I have it set. That really did a number on my energy when riding sand this weekend. Thought I was good to go in explorer. Ended ass up a few times to find I was in street mode. I'd remember to check every time if it was consistent.
Same. Sometimes is just goes to street mode. seems totally random.
 
1 - 12 of 12 Posts
Top